Which browsers are recommended to use with the Frontiers websites?

For better and stable performance of the Frontiers websites, we recommend the use of

a)   Internet Explorer 9 and newer versions (see notes)
b)   Chrome 32.x.x.x and newer versions
c)   Firefox 26 and newer versions
d)   Safari 6 and newer versions

Notes:
- There are some Browser extensions / plug-ins that could prevent web pages from being correctly displayed (e.g. AdBlock Plus, NoScript, etc...)
- We are currently addressing incompatibility issues between Internet Explorer and some parts of the site.